#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w{3,}-\w{3,}$"
Local $sString = "Text-Text" & @CRLF & _
"Abc-123" & @CRLF & _
"123-Abc" & @CRLF & _
"A2C-def4gk" & @CRLF & _
"Ab-3" & @CRLF & _
"Abc!-ajr4" & @CRLF & _
"a-bc3-25aj" & @CRLF & _
"a?c-b%"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")