package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w{3,}-\w{3,}$`)
var str = `Text-Text
Abc-123
123-Abc
A2C-def4gk
Ab-3
Abc!-ajr4
a-bc3-25aj
a?c-b%
déjà-vus`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}