$re = '/\D/m';
$str = '40\'000
40\'-00\'0
40\'*000
4*0_0-00';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;