const regex = /(?m)^.*\.$|\([^()]*\)|if\(.*?\/\/endif|(\b\d+\b)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)^.*\\.$|\\([^()]*\\)|if\\(.*?\\\/\\\/endif|(\\b\\d+\\b)', 'g')
const str = `cat 123 sat.
I like 000 not (456) though 111 is fine
222 if( //endif if(cat==789 stuff //endif 333`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}