const regex = /^((([1-9]\d{0,2}(,\d{3})*)(\.\d{1,4})?)|[1-9]\d*|(0\.\d{1,4})|0)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((([1-9]\\d{0,2}(,\\d{3})*)(\\.\\d{1,4})?)|[1-9]\\d*|(0\\.\\d{1,4})|0)$', 'gm')
const str = `2,000,000
200000.0000
200
200.00000
2,000.00
2,0,00.00
1,234,456.7890
0090
0333333333333.33
3
3.33
.33
0.88
1,000,000
1000,000
1,000000
1000000
0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}