import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((([1-9]\\d{0,2}(,\\d{3})*|[1-9]\\d*)(\\.\\d{1,4})?)|[1-9]\\d*|(0\\.\\d{1,4})|0)$";
final String string = "2,000,000\n"
+ "200000.0000\n"
+ "200\n"
+ "200.00000\n"
+ "2,000.00\n"
+ "2,0,00.00\n"
+ "1,234,456.7890\n"
+ "0090\n"
+ "0333333333333.33\n"
+ "3\n"
+ "3.33\n"
+ ".33\n"
+ "0.88\n"
+ "1,000,000\n"
+ "1000,000\n"
+ "1,000000\n"
+ "1000000\n"
+ "0\n"
+ "100.0000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}