// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)(?'indlvl'\s+)
if\(asd\)\n\s+\{\n\s+
(?:[\w\W]*)
\n\k'indlvl'\}").unwrap();
let string = "{
if(asd)
{
asd q=\"fg\"
{
q
}
}
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}