package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\$\{(?:.*pageContext.*|(.*))\}`)
var str = `${requestScope.user}
${sessionScope.user}
${pageContext.request}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}