$re = '/(?=-|\/|\s|#)|(?<=-|\/|\s|#)|(?!\d)(?=\d)|(?<=\d)(?=[^\d])|(?<=[a-z])|(?=[a-z])/m';
$str = 'MON-123ABC/456 78#AbCd';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;