package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)ACC[AG]CCG`)
var str = `ACCACCG
ACCGCCG
ACCCCG
ACCAGCCG`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}