import re
regex = re.compile(r"([\.]{0,1}[a-zA-Z]{1,}[0-9]{0,}?\.)|([a-zA-Z]+?\([\S\s]+?\))", flags=re.UNICODE)
test_str = ("lista.tekste2.push('asdsad', 'asd')\n\n"
".outrcoisa.lista.push(descricao,argumento2)\n\n"
".outrcoisa.lista.push(descricao,argumento3)\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")