# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*0[981]\.tgz$"
test_str = ("./backup_public_html_20160308.tgz\n"
"./backup_public_html_20160301.tgz\n"
"./backup_public_html_20160302.tgz\n"
"./backup_public_html_20160306.tgz\n"
"./backup_public_html_20160304.tgz\n"
"./backup_public_html_20160303.tgz\n"
"./backup_public_html_20160307.tgz\n"
"./backup_public_html_20160305.tgz\n"
"./backup_public_html_20160309.tgz\n"
"./backup_public_html_20160310.tgz")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.