$re = '/((?: DOCID)): (?<value>[0-9]+(\s+))/';
$str = 'DOCID: 0000011111 ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);