re = /(?:".*")|(\s+)/
str = 'dfgdfg fdgfd fd gfd g "Hello World!" sadfds dsfgsgdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end