re = /(?:\$\{(?P<braced>[_a-zA-Z][a-zA-Z0-9]*(?::[_a-zA-Z][_a-zA-Z0-9]*)+)\})|(?:\$(?P<named>[_a-zA-Z][a-zA-Z0-9]*(?::[_a-zA-Z][_a-zA-Z0-9]*)+))/
str = 'asdasd $asd:sd + ${asd123:asd} $HOME $$asd'
# Print the match result
str.match(re) do |match|
puts match.to_s
end