# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!(?:.*?-?\d\.\d+){4}\n)(.*)\n"
test_str = ("0 0.87 1.30 0.40 1.00\n"
" 0.94 1.21 0.20 0.95\n"
" 0.86 1.35 0.22 1.00\n"
" 0.69 1.39 0.33 1.00\n"
" 0.55 1.40 0.41 1.01\n"
" 0.52 1.38 0.41 1.00\n"
" 0.48 1.67 0.37 1.00\n"
" 0.46 1.62 0.38 0.98\n"
" 0.64 1.71 0.11 0.95\n"
" 0.69 1.74 0.05 0 .96\n"
" 0.83 1.74 0.00 0.95\n"
". 0.99. 1.64 0.09 00.91\n"
"5 6 1.14 6 1.56 7 0.247 08.91\n"
" 1.00 1.44 0.24 0.95\n"
" 0.86 1.60 0.09 0.90\n"
" 0.78 1.61 0.01 0.91\n"
" 0.72 1.62 -0.02 0.82\n"
" 0.81 1.59 -0.07 0.77\n"
" 0.73 1.53 0.01 0.82\n"
" 0.47 1.69 -0.08 0.80\n"
" 0.57 1.64 -0.02 0.82\n"
" 0.67 1.68 -0.02 0.82\n"
" 0.64 1.62 0.04 0.82\n"
" 0.68 1.71 -0.03 0.83\n"
" 0.67 1.77 -0.07 0.80\n"
" 0.84 1.70 -0.10 0.85\n"
" 0.99 1.68 -0.02 0.86\n"
" 1.01 1.43 0.03 0.86\n"
" 1.20 1.20 0.00 0.86\n"
" 1.55 1.17 0.09 0.83\n"
" 1.64 1.05 0.36 0.86\n"
" 1.59 1.15 0.42 0.83\n"
" 1.53 1.26 0.40 0.85\n"
" 1.46 1.18 0.26 0.82\n"
" 1.32 1.71 0.39 0.80\n"
" 1.56 1.41 0.66 0.88\n"
" 1.37 1.24 0.77 0.86\n"
" 1.18 1.46 0.41 0.88\n"
" 1.21 1.46 0.40 0.91\n"
" 0.94 1.41 0.25 0.85\n"
" 1.01 1.22 0.19 0.90\n"
" 1.05 1.08 0.2 3 0.88\n"
" 1.10 1.10 0.21 0.88\n"
". 0.98 1.09 00.23 0 0.911\n"
"6 6 1.06 7 0.90 7 0.480 08.88\n"
" 1.03 0.88 0.42 0.90\n"
" 1.00 0.95 0.48 0.90\n"
" 1.03 1.03 0.51 0.93\n"
" 0.83 1.41 0.10 0.90\n"
" 0.83 1.47 0.32 0.95\n"
" 1.12 1.46 0.48 0.91\n"
" 1.21 1.20 0.61 0.93\n"
" 1.51 1.22 0.38 0.90\n"
" 1.53 1.26 0.40 0.85\n"
" 1.64 1.14 0.38 0.82\n"
" 1.64 1.52 0.19 0.82\n"
" 1.48 1.59 0.18 0.86\n"
" 1.33 1.64 0.18 0.88\n"
" 1.26 1.61 0.21 0.91\n"
" 1.11 1.57 0.18 0.96\n"
" 0.96 1.63 0.00 0.95\n"
" 1.03 1.70 0.18 1.00\n"
" 1.11 1.71 0.18 1.00\n"
" 1.17 1.85 0.34 0.95\n"
" 1.25 1.82 0.23 0.91\n"
" 1.22 1.69 0.08 0.91\n"
" 1.49 1.60 0.16 0.82\n"
" 1.47 1.71 -0.04 0.82\n"
" 1.38 1.86 0.02 0.82\n"
" 1.63 1.73 0.12 0.84\n"
" 1.55 1.86 0.04 0.81\n"
" 1.68 1.84 0.32 0.86\n"
" 1.65 1.85 0.13 0.83\n"
" 1.62 1.8 6 0.06 0.76\n"
" 1.85 1.81 0.20 0.79\n"
" 2.02 10.89 0 0.04 1 0.711\n"
"7 2.074 1.583 -0.801 9 0.71\n"
" 1.65 1.76 0.06 0.71\n"
" 1.98 1.63 -0.03 0.74\n"
" 2.07 1.53 0.20 0.71\n"
" 2.18 1.53 0.30 0.71\n"
" 1.90 1.44 0.22 0.73\n"
" 1.72 1.57 -0.04 0.69\n"
" 1.68 1.67 0.00 0.71\n"
" 1.68 1.68 0.04 0.73\n"
" 1.71 1.70 0.12 0.73\n"
" 1.66 1.66 0.05 0.73\n"
" 1.67 1.65 0.05 0.73\n"
" 1.65 1.64 0.02 0.73\n"
" 1.60 1.56 -0.04 0.72\n"
" 1.63 1.55 0.01 0.70\n"
" 1.63 1.55 0.18 0.72\n"
" 1.93 1.40 0.25 0.79\n"
" 1.94 1.42 0.47 0.81\n"
" 1.99 1.49 0.46 0.78\n"
" 1.77 1.38 0.68 0.77\n"
" 1.77 1.49 0.78 0.74\n"
" 1.77 1.55 0.64 0.78\n"
" 1.91 1.38 0.57 0.76\n"
" 1.91 1.39 0.82 0.79\n"
" 1.84 1.45 0.86 0.79\n"
" 1.89 1.27 0.84 0.84\n"
" 1.45 1.41 0.74 0.83\n"
" 1.26 1.85 0.79 0.89\n"
" 1.35 1.83 0.53 0.83\n"
" 1.6 2 1.84 0.25 0.79\n"
" 1.67 2.01 -0.05 0.79\n"
" 01.64 02.05 1-0.101 0.281\n"
"7 1.862 1.896 90.21 9 0.76\n"
" 1.64 2.12 0.30 0.74\n"
" 1.41 2.33 0.21 0.76\n"
" 1.48 2.46 0.15 0.81\n"
" 1.38 2.40 0.05 0.79\n"
" 1.32 2.37 0.08 0.83\n"
" 1.30 2.33 -0.01 0.79\n"
" 1.36 2.04 -0.01 0.84\n"
" 1.57 1.88 -0.05 0.89\n"
" 1.82 1.82 0.04 0.92\n"
" 1.74 1.97 0.12 0.83\n"
" 1.45 2.04 0.18 0.86\n"
" 1.56 1.99 0.31 0.84\n"
" 1.73 1.90 0.26 0.89\n"
" 1.49 1.96 -0.02 0.83\n"
" 1.31 2.05 0.05 0.83\n"
" 1.31 1.97 0.17 0.78\n"
" 1.27 1.96 0.18 0.81\n"
" 1.22 1.86 0.38 0.85\n"
" 1.24 1.81 0.38 0.85\n"
" 1.41 1.65 0.39 0.93\n"
" 1.42 1.50 0.60 0.91\n"
" 1.40 1.55 0.61 0.90\n"
" 1.55 1.60 0.69 0.88\n"
" 1.51 1.60 0.73 0.83\n"
" 1.56 1.78 0.48 0.86\n"
" 1.65 1.59 0.45 0.84\n"
" 1.34 1.82 0.26 0.86\n"
" 1.16 1.80 0.22 0.85\n"
" 1.24 2.06 0.00 0.86\n"
" 1.59 1.94 -0.09 0.87\n"
"0 0 1.28 1 2.231 -0.124 02.81\n"
"8 18.20 92.16 9 0.10 0.81\n"
" 1.21 1.77 0.30 0.85\n"
" 1.42 1.73 0.11 0.85\n"
" 1.37 1.87 -0.08 0.87\n"
" 1.61 1.94 -0.13 0.83\n"
" 1.83 2.18 -0.20 0.84\n"
" 1.42 2.40 0.04 0.84\n"
" 1.29 2.38 -0.01 0.84\n"
" 1.36 2.12 -0.09 0.87\n"
" 1.02 2.13 -0.17 0.86\n"
" 1.21 1.91 0.04 0.86\n"
" 1.02 2.18 0.25 0.87\n"
" 0.86 2.26 0.16 0.89\n"
" 0.62 2.28 -0.02 0.89\n"
" 0.51 2.34 -0.02 0.92\n"
" 0.54 2.26 -0.02 0.94\n"
" 0.55 2.29 -0.01 0.96\n"
" 0.73 2.20 -0.01 0.91\n"
" 0.61 2.35 -0.13 0.89\n"
" 0.52 2.59 -0.01 0.83\n"
" 0.49 2.58 -0.43 0.79\n"
" 0.28 2.62 -0.75 0.68\n"
" 0.20 2.57 -0.71 0.61\n"
" 0.20 2.63 -0.58 0.63\n"
" 0.08 2.53 -0.32 0.64\n"
" 0.03 2.46 -0.26 0.66\n"
" 0.08 2.46 -0.26 0.66\n"
" 0.30 2.13 -0.18 0.63\n"
" 0.23 2.17 -0.08 0.65\n"
" -0.02 2.17 -0.04 0.63\n"
" 0.17 1.90 -0.02 0.62\n"
"1 0.151 1.924 0.224 30.62\n"
"8 90.15 91.97 0.28 0.67\n"
" 0.31 2.04 0.18 0.67\n"
" 0.52 1.56 0.24 0.70\n"
" 0.84 1.33 0.51 0.77\n"
" 1.18 1.26 0.67 0.83\n"
" 1.09 1.22 0.64 0.95\n"
" 1.17 1.41 0.61 0.93\n"
" 1.10 1.47 0.78 0.93\n"
" 0.96 1.74 0.80 0.88\n"
" 0.84 1.74 0.72 0.83\n"
" 0.86 1.90 0.71 0.91\n"
" 0.75 1.84 0.71 0.88\n"
" 0.79 1.89 0.70 0.88\n"
" 0.82 1.82 0.65 0.95\n"
" 1.02 1.56 0.72 0.93\n"
" 1.48 1.58 0.88 0.93\n"
" 1.74 1.67 0.61 0.92\n"
" 1.63 1.31 0.61 0.86\n"
" 1.66 1.29 0.56 0.85\n"
" 1.75 1.62 0.39 0.83\n"
" 1.71 1.55 0.11 0.82\n"
" 1.75 1.55 0.13 0.86\n"
" 1.85 1.64 0.06 0.84\n"
" 1.83 1.59 -0.01 0.84\n"
" 1.80 1.47 0.13 0.84\n"
" 1.91 1.33 0.15 0.86\n"
" 1.81 1.43 0.17 0.85\n"
" 1.77 1.47 0.00 0.85\n"
" 1.71 1.60 0.08 0.84\n"
" 1.78 1.54 0.07 0.86\n"
" 1.81 1.26 0.09 0.86\n"
"1 1.724 1.128 03.09 3 0.86\n"
"9 9 1.65 1.35 -0.04 0.86\n"
" 1.55 1.45 -0.18 0.86\n"
" 1.65 1.35 -0.06 0.90\n"
" 1.58 1.30 0.17 0.91\n"
" 1.49 1.08 0.24 0.90\n"
" 1.60 1.09 0.36 0.93\n"
" 1.65 0.91 0.58 0.91\n"
" 1.55 1.15 0.75 0.95\n"
" 1.53 1.21 0.25 0.91\n"
" 1.65 1.26 0.40 0.93\n"
" 1.53 1.38 0.40 0.95\n"
" 1.51 1.42 0.44 0.96\n"
" 1.46 1.34 0.33 0.95\n"
" 1.47 1.30 0.06 0.91\n"
" 1.30 1.24 0.17 0.91\n"
" 1.53 1.31 0.16 0.96\n"
" 1.58 1.25 0.04 0.96\n"
" 1.42 1.14 0.03 0.90\n"
" 1.50 1.51 -0.19 0.88\n"
" 1.68 1.34 -0.37 0.80\n"
" 1.51 1.19 -0.38 0.78\n"
" 1.53 1.02 -0.43 0.78\n"
" 1.56 1.15 -0.30 0.82\n"
" 1.69 0.99 -0.20 0.78\n"
" 1.48 0.74 0.08 0.78\n"
" 1.53 0.67 0.30 0.80\n"
" 1.66 0.55 0.63 0.7\n"
"2\n"
" 1.53 0.82 0.91 0.77\n"
" 1.05 0.57 1.09 0.80\n"
" 1.26 0.44 0.46 0.88\n"
" 0.78 0.81 -0.32 0.86\n"
"2 1.201 13.24 -30.48 4 0.940\n"
" 1.25 0.90 0.07 0.95\n"
" 1.19 0.88 0.63 0.93\n"
" 1.04 1.26 0.91 0.95\n"
" 0.39 1.34 0.10 0.95\n"
" 0.44 1.18 0.56 0.96\n"
" 0.26 1.46 0.02 0.96\n"
" -0.04 1.56 0.40 0.96\n"
" 0.30 1.72 0.28 1.05\n"
" -0.41 1.61 0.05 0.95\n"
" -0.19 1.74 -0.56 1.00\n"
" -0.07 1.69 -0.75 0.90\n"
" -0.27 1.34 -0.43 0.83\n"
" 0.01 1.13 -0.17 0.91\n"
" 0.07 1.30 -0.30 0.95\n"
" -0.06 1.47 -0.25 0.91\n"
" -0.44 0.83 0.30 0.91\n"
" -0.07 1.11 0.38 0.95\n"
" 0.14 0.58 0.20 0.93\n"
" 0.20 0.88 0.17 0.95\n"
" 0.30 1.29 0.26 1.00\n"
" 0.60 1.20 -0.07 0.98\n"
" 0.43 0.92 0.00 0.91\n"
" 0.29 1.45 -0.19 0.95\n"
" 0.24 1.33 -0.39 0.88\n"
" 0.28 1.07 -0.69 0.85\n"
" 0.91 0.75 -0.70 0.83\n"
" 0.71 1.05 -0.6\n"
"8 0\n"
".73\n"
" \n"
" 1.84 2.35 -0.21 0.78\n"
" 1.72 2.35 0.35 0.81\n"
" 1.69 2.06 0.32 0.84\n"
" 1.58 2.10 -0.01 0.78\n"
" 2.04 1.67 -0.43 0.78\n"
" 2.07 1.41 -0.14 0.73\n"
" 1.96 1.52 -0.16 0.73\n"
" 2.01 1.37 0.03 0.74\n"
" 1.61 1.85 0.38 0.78\n"
" 1.66 1.90 0.56 0.81\n"
" 2.08 1.62 0.47 0.76\n"
" 2.33 1.63 1.15 0.84\n"
" 2.06 2.06 1.15 0.79\n"
" 2.96 1.51 0.43 0.82\n"
" 2.73 1.93 0.74 0.74\n"
" 2.99 2.11 0.45 0.65\n"
" 2.96 2.26 1.28 0.67\n"
" 3.23 2.49 0.95 0.70\n"
" 3.71 2.71 0.30 0.68\n"
" 3.73 2.36 0.42 0.73\n"
" 3.60 2.23 -0.01 0.75\n"
" 3.59 2.16 -0.09 0.76\n"
" 3.49 2.62 -0.05 0.73\n"
" 3.44 2.50 -0.23 0.71\n"
" 3.21 2.30 -0.15 0.72\n"
" 2.89 2.30 -0.24 0.72\n"
" 2.730 2.250 0.111 10.67\n"
"7 7 3.01 8 2.168 0.592 09.74\n"
" 3.29 2.01 0.68 0.80\n"
" 3.09 1.96 0.64 0.79\n"
" 3.06 1.99 0.72 0.75\n"
" 2.99 1.90 1.15 0.75\n"
" 2.70 2.62 0.44 0.75\n"
" 2.49 2.78 -0.05 0.77\n"
" 2.77 2.77 -0.19 0.75\n"
" 2.93 2.28 -0.12 0.72\n"
" 2.81 2.47 -0.20 0.75\n"
" 2.75 2.63 -0.14 0.72\n"
" 2.68 2.65 -0.12 0.72\n"
" 2.66 2.72 0.15 0.69\n"
" 2.53 2.69 0.44 0.75\n"
" 2.57 2.05 0.16 0.75\n"
" 2.63 1.72 -0.07 0.71\n"
" 2.66 2.12 0.02 0.77\n"
" 2.84 1.72 -0.42 0.74\n"
" 2.87 1.76 -0.36 0.75\n"
" 2.84 1.79 -0.12 0.74\n"
" 2.68 1.73 -0.12 0.73\n"
" 2.33 2.19 -0.29 0.71\n"
" 2.27 2.03 -0.32 0.78\n"
" 2.38 1.75 -0.10 0.73\n"
" 2.32 1.74 -0.20 0.74\n"
"9 2.51 1.36 -0.29 0.73\n"
" 2.37 1.49 0.14 0.76\n"
" 2.35 1.62 0.40 0.78\n"
" 2.37 1.41 0.80 0.74\n"
" 2.45 1.46 1.00 0.78\n"
" 2.51 2.08 0.83 0.88\n"
"0 2.604 2.103 01.94 2 0.792\n"
"7 8 2.88 8 2.289 0.092 0.70\n"
" 3.06 2.20 -0.01 0.75\n"
" 2.96 2.49 0.31 0.74\n"
" 2.67 2.75 0.22 0.77\n"
" 2.83 2.65 -0.01 0.79\n"
" 2.84 2.23 -0.14 0.77\n"
" 2.69 1.95 -0.06 0.80\n"
" 2.56 1.81 -0.20 0.76\n"
" 2.37 2.11 0.00 0.78\n"
" 2.48 1.58 0.46 0.74\n"
" 2.73 1.71 0.99 0.82\n"
" 3.10 2.00 0.61 0.74\n"
" 2.91 1.94 -0.01 0.77\n"
" 3.30 1.96 0.11 0.72\n"
" 3.17 2.01 0.44 0.79\n"
" 3.63 1.72 1.05 0.80\n"
" 3.45 1.46 0.90 0.79\n"
" 3.37 1.58 0.88 0.82\n"
" 2.89 1.96 0.45 0.77\n"
" 3.18 2.17 0.34 0.70\n"
" 3.28 2.39 0.30 0.70\n"
" 3.18 2.40 0.37 0.70\n"
" 3.18 2.28 0.32 0.70\n"
" 3.09 2.29 0.32 0.72\n"
" 2.96 2.24 0.33 0.75\n"
" 3.08 1.86 0.58 0.72\n"
" 3.03 1.86 0.58 0.72\n"
" 2.82 1.78 0.54 0.74\n"
" 2.73 1.50 0.87 0.71\n"
" 2.58 1.74 0.63 0.69\n"
" 2.72 2.16 0.50 0.75\n"
"0 2.163 2.131 02.52 2 0.723\n"
"8 2.549 2.493 0.06 0.77\n"
" 2.50 2.56 -0.01 0.70\n"
" 2.46 2.46 -0.33 0.74\n"
" 2.57 2.04 -0.36 0.75\n"
" 2.60 2.60 -0.21 0.74\n"
" 2.65 2.53 -0.14 0.77\n"
" 2.55 2.55 -0.54 0.77\n"
" 2.53 2.57 -0.42 0.75\n"
" 2.37 2.22 -0.14 0.74\n"
" 2.67 2.10 -0.13 0.79\n"
" 2.69 1.97 -0.31 0.75\n"
" 2.73 2.13 -0.10 0.70\n"
" 2.65 2.37 -0.07 0.77\n"
" 2.71 2.33 0.05 0.70\n"
" 2.94 2.40 0.00 0.69\n"
" 2.80 2.18 0.15 0.69\n"
" 2.63 2.20 0.26 0.70\n"
" 2.98 1.97 0.31 0.70\n"
" 2.86 1.73 0.65 0.67\n"
" 2.39 1.91 -0.06 0.66\n"
" 2.35 2.15 -0.26 0.71\n"
" 2.27 2.40 -0.18 0.72\n"
" 2.33 2.25 -0.02 0.71\n"
" 2.53 2.14 -0.07 0.70\n"
" 2.25 1.99 0.13 0.69\n"
" 2.15 2.07 -0.16 0.71\n"
" 2.07 2.13 -0.11 0.69\n"
" 2.28 2.14 -0.03 0.69\n"
" 2.44 2.44 -0.02 0.77\n"
" 2.66 2.05 -0.19 0.74\n"
" 2.49 1.77 -0.38 0.74\n"
"1 21.54 12.55 2-0.27 3 0.733\n"
"9 2.492 1.64 -0.23 0.69\n"
" 2.39 1.65 -0.16 0.71\n"
" 2.49 1.80 -0.06 0.68\n"
" 2.64 1.58 0.15 0.73\n"
" 2.68 1.83 0.09 0.64\n"
" 3.29 1.83 -0.17 0.72\n"
" 2.81 2.46 -0.47 0.70\n"
" 3.04 2.20 -0.25 0.74\n"
" 3.40 2.26 0.23 0.70\n"
" 3.17 2.62 0.12 0.73\n"
" 2.96 2.65 -0.37 0.75\n"
" 2.89 2.79 -0.41 0.76\n"
" 2.65 2.52 -0.72 0.74\n"
" 2.83 2.52 -0.48 0.75\n"
" 2.91 2.66 -0.65 0.72\n"
" 2.81 2.75 -0.80 0.75\n"
" 2.82 2.65 -0.67 0.77\n"
" 2.98 2.51 -0.57 0.80\n"
" 2.81 2.31 -0.79 0.74\n"
" 2.87 2.52 -0.85 0.77\n"
" 2.92 2.41 -0.88 0.77\n"
" 3.05 2.05 -0.72 0.75\n"
" 3.05 1.92 -0.51 0.77\n"
" 2.87 1.95 -0.58 0.77\n"
" 2.95 2.10 -0.45 0.75\n"
" 2.90 2.06 -0.26 0.72\n"
" 2.84 1.91 -0.31 0.70\n\n"
" 2.89 1.92 -0.25 0.75\n"
" 2.73 2.10 -0.41 0.75\n"
" 2.54 2.21 -0.66 0.74\n"
" 2.63 2.20 -0.73 0.77\n"
"1 22.81 22.21 3-0.47 3 0.740\n"
"9 2.65 2.45 -0.35 0.70\n"
" 2.50 2.51 -0.31 0.77\n"
" 2.33 2.35 -0.84 0.80\n"
" 2.28 1.91 -0.71 0.76\n"
" 2.07 2.15 -0.83 0.76\n"
" 2.31 2.16 -0.87 0.74\n"
" 2.28 1.82 -0.80 0.76\n"
" 2.10 1.76 -0.70 0.84\n"
" 1.96 1.71 -0.82 0.81\n"
" 2.12 1.78 -0.56 0.76\n"
" 2.14 1.94 -0.47 0.74\n"
" 1.93 1.92 -0.44 0.78\n"
" 2.15 1.81 -0.30 0.73\n"
" 2.15 1.77 -0.15 0.69\n"
" 2.12 1.93 -0.11 0.74\n"
" 2.05 1.69 -0.19 0.71\n"
" 2.10 1.81 -0.02 0.78\n"
" 2.04 1.73 -0.41 0.69\n"
" 2.00 1.65 -0.29 0.71\n"
" 1.85 1.72 -0.35 0.74\n"
" 1.91 1.67 -0.41 0.73\n"
" 2.05 1.64 -0.62 0.71\n"
" 2.26 1.69 -0.40 0.68\n"
" 2.21 1.89 -0.42 0.76\n"
" 2.42 2.10 -0.61 0.79\n"
" 2.32 2.11 -0.72 0.83\n"
" 2.28 1.90 -0.82 \n"
" 0.79\n\n"
" 2.29 2.15 -0.91 0.78\n"
" 2.44 2.16 -0.49 0.77\n"
" 2.31 2.16 -0.72 0.79\n"
" 2.48 2.24 -0.61 0.79\n"
"2 22.57 32.38 3-0.574 0.474\n"
" 2.17 2.41 -0.62 0.80\n"
" 2.19 2.42 -0.64 0.82\n"
" 2.47 2.42 -0.69 0.80\n"
" 2.72 2.48 -0.75 0.77\n"
" 2.82 2.51 -0.48 0.79\n"
" 2.61 2.59 -0.62 0.80\n"
" 2.74 2.58 -0.60 0.80\n"
" 2.58 2.55 -0.74 0.80\n"
" 2.46 2.40 -0.69 0.79\n"
" 2.53 2.44 -0.49 0.77\n"
" 2.39 2.50 -0.74 0.80\n"
" 2.42 2.70 -0.59 0.82\n"
" 2.40 2.51 -0.41 0.79\n"
" 2.43 2.61 -0.52 0.79\n"
" 2.76 2.93 -0.54 0.80\n"
" 2.71 2.71 -0.99 0.67\n"
" 2.68 2.67 -0.76 0.72\n"
" 2.63 3.63 -0.16 0.68\n"
" 2.16 3.57 -0.52 0.78\n"
" 2.20 3.05 -0.94 0.69\n"
" 2.45 2.64 -0.93 0.62\n"
" 2.79 2.50 -0.55 0.74\n"
" 2.82 2.76 -0.28 0.72\n"
" 2.60 2.59 -0.87 0.72\n"
" 2.19 3.00 -0.76 0.70\n"
" 2.00 2.41 -0.37 0.68\n"
" 1.97 2.24 \n"
" 0.00 \n"
" 0.74\n"
" 2.04 2.39 0.06 0.78\n"
" 2.44 2.03 0.30 0.78\n"
" 2.76 2.24 -0.09 0.75\n"
" 2.99 2.09 -0.03 -0.69\n"
"2 3 2.84 3 2.06 4 0.044 05.77\n"
" 3.17 2.27 0.11 0.75\n"
" 3.10 2.16 0.16 0.75\n"
" 2.83 2.28 0.47 0.70\n"
" 2.69 2.41 -0.08 0.74\n"
" 2.65 2.71 -0.21 0.80\n"
" 2.66 2.48 -0.47 0.75\n"
" 2.83 2.07 -0.12 0.77\n"
" 3.02 2.18 -0.01 0.70\n"
" 3.06 2.19 0.32 0.72\n"
" 2.89 2.09 0.50 0.72\n"
" 2.82 2.00 0.43 0.64\n"
" 2.46 2.19 0.32 0.74\n"
" 2.61 2.42 0.55 0.72\n"
" 2.68 2.56 0.04 0.74\n"
" 3.24 2.64 0.13 0.75\n"
" 2.96 2.44 -0.34 0.64\n"
" 3.12 2.61 -0.34 0.65\n"
" 2.91 2.50 -0.42 0.65\n"
" 2.72 2.72 -0.30 0.67\n"
" 2.61 2.68 -0.25 0.65\n"
" 2.79 2.78 -0.50 0.67\n"
" 3.13 2.42 -0.71 0.70\n"
" 3.12 1.93 -0.34 0.67\n"
" 2.72 1.84 -0.21 0.65\n"
" 2.60 2.15 -0.37 0.67\n"
" 2.65 1.94 0.01 0.65\n"
" 2.63 \n"
"1.77 \n"
" 0.15 0.69\n"
" 2.73 2.18 -0.13 0.67\n"
" 2.90 2.90 -0.16 0.65\n"
" 2.60 2.97 -0.42 0.72\n"
" 2.30 2.94 -0-.50 - 0.72.\n"
"3 3 2.28 4 2.934 -0.573 50.74\n"
" 2.41 2.67 -0.23 0.74\n"
" 2.48 2.87 -0.21 0.75\n"
" 2.31 2.65 -0.40 0.72\n"
" 2.46 2.94 -0.29 0.67\n"
" 2.45 3.03 0.25 0.65\n"
" 2.43 2.90 0.21 0.70\n"
" 3.12 2.35 0.40 0.77\n"
" 2.93 2.34 0.65 0.72\n"
" 2.66 1.80 0.92 0.80\n"
" 2.36 1.61 0.78 0.74\n"
" 2.44 1.55 0.99 0.76\n"
" 2.27 1.09 0.74 0.84\n"
" 2.64 1.06 0.41 0.79\n"
" 2.83 1.03 0.37 0.76\n"
" 2.32 1.57 0.60 0.66\n"
" 2.81 1.76 0.51 0.79\n"
" 2.40 1.68 0.35 0.76\n"
" 2.27 1.65 0.86 0.66\n"
" 2.76 1.51 0.78 0.74\n"
" 2.49 1.47 0.61 0.76\n"
" 2.45 1.13 0.95 0.74\n"
" 2.20 1.54 0.92 0.74\n"
" 2.15 1.69 0.91 0.79\n"
" 2.05 1.83 0.67 0.83\n"
" 1.76 1.88 0.60 0.79\n"
" 1.72 2.07 0.76 0.83\n"
" \n"
" 2.17 \n"
" 1.97 0.03 0.84\n"
" 1.90 2.02 0.33 0.74\n"
" 1.69 2.42 -0.08 0.83\n"
" 1.63 2.46 -0.16 0.84\n"
" 1.83 2-.35 -0.03 . 0.8.1\n"
"4 2.034 2.359 0.509 60.84\n"
" 1.73 2.24 0.06 0.76\n"
" 1.40 2.27 -0.05 0.81\n"
" 1.12 2.03 -0.16 0.79\n"
" 0.98 2.24 -0.17 0.76\n"
" 1.12 2.28 -0.05 0.83\n"
" 1.21 1.78 -0.04 0.82\n"
" 1.24 2.09 0.38 0.87\n"
" 1.68 1.78 0.39 0.87\n"
" 1.34 1.73 0.20 0.91\n"
" 1.27 1.82 0.00 0.91\n"
" 1.17 1.84 0.34 0.88\n"
" 1.07 1.93 0.16 0.86\n"
" 1.28 2.01 0.25 0.89\n"
" 1.75 2.14 0.38 0.84\n"
" 1.74 2.19 0.22 0.83\n"
" 1.63 2.20 0.17 0.86\n"
" 1.81 1.92 0.31 0.87\n"
" 2.00 2.06 0.40 0.91\n"
" 2.21 2.07 0.15 0.83\n"
" 2.18 2.18 0.04 0.74\n"
" 2.13 2.27 0.11 0.76\n"
" 1.69 2.30 -0.01 0.79\n"
" 1.44 2.38 -0.29 0.78\n"
" 2.64 2.31 -0.12 0.67\n"
" 2.76 2.07 0.00 0.82\n"
" 2.69 2.28 -0.18 0.77")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.