$re = '/^(\+)|\D+/m';
$str = '+1234abc567+';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;