$re = '/.(?= ago)/m';
$str = '3 days ago
6 hours ago
6 hours ago
9 minutes ago';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);