$re = '/(\d+)\s+((?:[A-Za-zA-Z0-9]{0,3})+)\s+((?:[A-Za-z0-9\)\(\]\:\/<>\[\"\.\,\+\'\-]{2,} ?)+)\s+(\d{2,7}-\d{2}-\d)/';
$str = '1 CH4 Methane 74-82-8
2 C2H2 Ethyne 74-86-2
5 C3H4 Propadiene 463-49-0
6 C3H4 Propyne 74-99-7
7 C3H6 Cyclopropane 75-19-4
10 C4H2 Butadiyne, Diacetylene 460-12-8
11 C4H4 1-Buten-3-yne, Vinylacetylene 689-97-4
12 C4H6 1,2-Butadiene 590-19-2
14 C4H6 Dibenzo[b,e]oxepine 107-00-6
16 C4H6 Cyclobutene 822-35-5
17 C4H8 1-Butene 106-98-9
18 C4H8 (E)-2-Butene 624-64-6
19 C4H8 (Z)-2-Butene 590-18-1
22 C4H8 Pyrazolo[4\',3\':6,7]oxepino[4,5-b]indole 115-11-7
23 C4H10 Butane 106-97-8
27 C5H8 Bicyclo[2.1.0]pentane 185-94-4
29 C5H8 3-Methyl-1-butyne 598-23-2
35 C5H8 (E)-1,3-Pentadiene 2004-70-8
41 C5H8 Spiro[2.2]pentane 157-40-4
45 C5H10 cis-1,2-Dimethylcyclopropane 930-18-7
66 C6H8 cis, anti, cis-Tricyclo[3.1.0.0(2,4)]hexane 21531-33-9
70 C6H10 2,3-Dimethyl-1,3-butadiene 513-81-5
71 C6H10 [1,1\'-Binaphthalene]-3,3\',4,4\'-tetramine 513-81-5
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);