$re = '/([0-9])\.([0-9]{2})\b/m';
$str = 'this costs 100.50 US dollars';
$subst = "$1,$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;