$re = '/.*?agreement[\w\W]*?(as of|by and between|among)[\w\W]*?(as of|by and between|among).*/i';
$str = 'CREDIT AGREEMENT (this “Agreement”) dated as of August 1, 2012, among HAEMONETICS CORPORATION, a Massachusetts corporation (the “Company”), the LENDERS from time to time party hereto, and JPMORGAN CHASE BANK, N.A., as Administrative Agent.
THIS LOCK UP AGREEMENT (the “ Agreement”) is entered into as of this 19th day of December, 2014 (the “ Effective Date”) by and between _______________________ (the “ Stockholder”) and Social Reality, Inc., a Delaware corporation (the “ Company”).
This Fifth Amendment to the Credit Card Program Agreement (“Fifth Amendment”) is made and entered into as of August 31, 2010 (“Effective Date”) by and between HSBC Bank Nevada, National Association (“HSBC” or “Bank”), and The Bon-Ton Stores, Inc. (“Bon-Ton”) and amends that certain Credit Card Program Agreement dated as of June 20, 2005, as previously amended (“Agreement”).
This Executive Employment Agreement (“ Agreement”) is entered into as of January 23, 2017 (the “ Effective Date”), by and between Lilis Energy, Inc. (the “ Company”) and Joseph C. Daches (“ Executive”). Executive and the Company are each referred to individually as a “ Party” and collectively as the “ Parties.”
STOCK PURCHASE AGREEMENT
by and between
EVESTMENT ALLIANCE HOLDINGS, LLC,
FUNDSPIRE, INC.
and
THE STOCKHOLDERS OF FUNDSPIRE, INC.
Dated as of October 31, 2012
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);