import re
regex = re.compile(r"(?<=id=\"_wpnonce\" name=\"_wpnonce\" value=\")(.*?)\"")
test_str = ("<form method=\"post\" enctype=\"multipart/form-data\" class=\"wp-upload-form\" action=\"http://localhost/wp-admin/update.php?action=upload-plugin\">\n"
" <input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"a7a9167537\"><input type=\"hidden\" name=\"_wp_http_referer\" value=\"/wp-admin/plugin-install.php?tab=upload\"> <label class=\"screen-reader-text\" for=\"pluginzip\">Plugin zip file</label>\n"
" <input type=\"file\" id=\"pluginzip\" name=\"pluginzip\">\n"
" <input type=\"submit\" name=\"install-plugin-submit\" id=\"install-plugin-submit\" class=\"button\" value=\"Install Now\" disabled=\"\"> </form>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")