import re
regex = re.compile(r"<\s*?script\s*?([^>]*)\s*?>\s*?(.+)?\s*?<\s*?\/script\s*?>", flags=re.DOTALL)
test_str = ("< script type=\"text/javascript\" src=\"//vk.com/js/api/openapi.js?65\"> < /script >\n\n"
"<script type=\"text/javascript\" >\n"
" VK.init({apiId: 3251711, onlyWidgets: true});\n"
"</script>\n\n"
"<script type=\"text/javascript\" src=\"http://keddr.com/wp-content/themes/keddr3-1/js/lite-youtube.js\" ></script>\n\n"
"<script type=\"text/javascript\" src=\"http://keddr.com/wp-content/themes/keddr3-1/js/jquery.complexify.js\" > sfdbb </script>\n\n"
"<script type=\"text/javascript\" >\n"
" $(function () {\n"
" if (($(\"#pass1\").length 0)) {\n"
" $(\"#pass1\").complexify({}, function (valid, complexity) {\n"
" if (complexity < 1) {\n"
" $('#progress').css({'width': complexity + '%'}).removeClass('progressbarValidGood').addClass('progressbarInvalid');\n"
" $('.passAlert').hide();\n"
" } else if (complexity > 1 && complexity < 40) {\n"
" $('#progress').css({'width': complexity + '%'}).removeClass('progressbarValidGood').addClass('progressbarInvalid');\n"
" $('.passAlert.good').hide();\n"
" $('.passAlert.bad').fadeIn();\n"
" } else if (complexity > 40) {\n"
" $('#progress').css({'width': complexity + '%'}).removeClass('progressbarValidGood').addClass('progressbarValid');\n"
" $('.passAlert.good').hide();\n"
" $('.passAlert.strong').fadeIn();\n"
" }\n"
" $('#complexity').html(Math.round(complexity) + '%');\n"
" });\n"
" }\n"
" }); \n"
" \n"
"</script >")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")