const regex = /<span .+?(?=>)>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<span .+?(?=>)>', '')
const str = `<span style="color: #0000ff">public</span> <span style="color: #0000ff">class</span>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}