import re
regex = re.compile(r"^(lib32-[a-zA-Z0-9\.\-]*?)\-[0-9\.]*\-[0-9\.]$", flags=re.MULTILINE)
test_str = ("lib32-bluez-libs-5.41-1\n"
"lib32-dbus-glib-0.106-1\n"
"lib32-gconf-3.2.6-1\n"
"lib32-jansson-2.7-2\n"
"lib32-kmod-22-1\n"
"lib32-libdaemon-0.14-4\n"
"lib32-libical-2.0.0-3\n"
"lib32-libmbim-1.12.4-1\n"
"lib32-libmm-glib-1.4.14-2\n"
"lib32-libndp-1.6-1\n"
"lib32-libnm-glib-1.2.2-1\n"
"lib32-libqmi-1.12.10-1\n"
"lib32-libteam-1.23-1\n"
"lib32-libudev0-182-2")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)