package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`_[^\/]+(\.[^\/]*)$`)
var str = `http://example.com/uploads/images/a51dd42_thumb.jpg`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}