$re = '/^(N[BFH][AL])(?:.*)(202\d)(?:\WWeek \d+)?\W(?:\W*|(.*)\W)(\d\d).(\d\d)\W(?:PS\W)?(\D*)\W?(?:.*\.)(mkv|mp4)$/mi';
$str = 'NBA PS 2022 Washington Wizards vs Golden State Warriors 01 10 576pEN60fps.mkv
NHL PS 2022 New Jersey Devils vs New York Rangers 29 09 720pEN30fps.mkv
NFL 2022 Week 3 Cowboys vs Giants Condensed Game 26 09 720pEN30fps.mkv
NHL PS 2022 New York Islanders vs New Jersey Devils 27 09 720pEN30fps.mkv
NFL 2022 Week 3 Dallas Cowboys vs New York Giants 26 09 720pEN30fps.mkv
NHL PS 2022 New York Islanders vs New York Rangers 26 09 720pEN30fps NHLN.mkv
NhHL 2022 Seattle Kraken vs Vancouver Canucks 29 09 720pEN30fps.mkv
NHL PS 2022 New York Rangers vs Boston Bruins 27 09 720pEN30fps.mkv
NHL 2022-09-24 PS Boston Bruins vs Philadelphia Flyers 720p60_EN_NBCSP.mkv
NHL PS 2022 New York Rangers vs New Jersey Devils 30 09 720pEN30fps.mkv
NHL 2022-09-26 PS New York Islanders vs New York Rangers 720p60_EN_MSGSN.mkv
NHL PS 2022 Ottawa Senators vs Winnipeg Jets 27 09 720pEN30fps.mkv
NHL 2022-09-27 Pre-Season Red Wings vs. Penguins 720p - English.mp4
NHL PS 2022 St. Louis Blues vs. Chicago Blackhawks 27 09 720pEN30fps.mkv
NHL 2022-09-27 PS Ottawa Senators vs Winnipeg Jets 720p60_EN_TSN3.mkv
NHL PS 2022 Washington Capitals vs Philadelphia Flyers 28 09 720pEN30fps.mkv
NHL 2022-09-28 PS Chicago Blackhawks vs Detroit Red Wings 720p60_EN_BSDET.mkv
NHL PS 2022 Winnipeg Jets vs. Edmonton Oilers 27 09 720pEN30fps.mkv';
$subst = "$1 - $2-$4-$5 - $3$6.$7";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;