import re
regex = re.compile(r"^[0-9a-f]{1,2}([\.:-])(?:[0-9a-f]{1,2}\1){4}[0-9a-f]{1,2}$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("AA-BB.CC.DD.EE.FF\n"
"AA.BB.CC.DD.EE.FF")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")