$re = '/^xyz\.[^.]*\.abc\.com$/mi';
$str = 'xyz.east.abc.com
xyz.*.abc.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);