$re = '/\b\d+\b/mi';
$str = 'Ack 9876 3456 3467 4578 4567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);