$re = '/\d{3}\s.*?\s\d{3}/i';
$str = '324 sdfsdf 432';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);