using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(10[.][0-9]{4,}(?:[.][0-9]+)*/(?:(?![""&\'])\S)+)\b";
string input = @"http://dx.doi.org/10.978.8896471/333
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}