use strict;
my $str = 'zweigeshoff@southwestern.com
Zwarren@tristatetruck.com
zoning@jeffersoncountytn.gov
znunley@fpcnashville.org
ZMYERS@NPMMG.COM
zmart.stations@gmail.com
ZLOVELADY@AZORINC.COM
zlinkous0904@musfiber.com
zjackson@guardianhealthcare.com
zippyrf@gmail.com
zimmermanm@wcschools.com
zhou2209@hotmail.com
zhashmi@ornlfcu.com
ZGANN@TEMPLEHILLSGOLF.COM
zfoster@spicerfirm.com
zeisloftsb@msha.com
zdut@aol.com
Zc@poncelaw.com
zazzyz@gmail.com
zahuczkyj@wcschools.com
zacharyebryant@mac.com
zachary.moore@mnps.org
zacharc@wcschools.com
zac.seiber@ttecasting.com
YVONNER@CAPITOLCASH1.COM
yvonne.rossi@starpt.COM
yvonne.leonard@cumulus.com
YVONNE.CHELTON@MNPS.ORG
Yvette.Robinson@Nashville.gov
yroebuck@pstcc.edu
YPARR@UTM.EDU
YOUNKERJ@BELLSOUTH.NET
YOUNGSHIL27@YAHOO.COM
youngs.animal.hospital@comcast.net
Youngde@rcschools.net
youngbs@msha.com
youngab@msha.com
young.vickiel@yahoo.com
younce@crossroadstn.com
yorkke@msha.com
yohel@rcschools.net
YMJ@ROWLANDANDCARTER.COM
yjoyner@ci.collierville.tn.us
yjones@tcatcovington.edu
yhanash@comcast.net
YHALL@OLDREPUBLICTITLE.COM
yfrazier@mmc.edu
yercheckta@msha.com
YEAGER.KRISTEN@COGENTHMG.COM
YDONATTO@OAKWOOD.EDU
ycutler@bellsouth.net
ycollier@aol.com
YCARPENTER@VOLUNTEEREXPRESS.COM
yateskh@msha.com
yarberbf@msha.com
yakima.wa@carehere.com
xxx
xcovington14@yahoo.com
XAVIERA.WASHINGTON@MNPS.ORG
WynneJL2@msha.com
wyelverton@madisoncountyal.gov
wyattj@rcschools.net
wyatt@suppliesnetwork.com
WWW.VERTKSOLUTIONSINC.COM
WWW.VERTEKSOLUTIONSINC.COM
WWW.TURNERCONSTRUCTION.COM
WWW.TLSINC.COM
WWW.THEHANNAHCOMPANY.COM
WWW.TEAMNOXCUSE.COM
WWW.SPICERFIRM.COM
WWW.SENTRYSTEEL.COM
www.northsidedisiples.com
WWW.MONARCHMORTGAGETN.COM
WWW.LIGHTWAVESOLARELECTRIC.COM
www.innovative-eyecare.com
www.holisticalabama.com
www.decantermachine.com
WWW.BACKFIELDINMOTION.ORG
www.athens-orthodontics.com
www.allneedzrental.com
WWW.ALLERGYASC.COM
WWTPLANT@PULASKI-TN.COM
WWHITESIDE@HARDINANDPARKES.COM
WWHITE@CBCDECATUR.ORG
wweaver@alphapetinc.com
wwatkins@rutherfordcountytn.gov
wwasserman@vofonline.org
Wwalls@Systemstechnologyco.com
WVENABLE@CITYOFSCOTTSBORO.COM
WVAUGHN@OAKWOOD.EDU
wurmserbp@msha.com
WTROPER@HSVUTIL.ORG
wths@bellsouth.net
wthayer@dyersburgtn.gov
WTERRY@DECATUR-AL.GOV
';
my $regex = qr/(\r\n|\n|\r|\t)/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}