use strict;
my $str = 'sdfgsdfgsdfg sdfg dsfg sdfg sdfg dsfg dsfg sd
sdfgsdfgsdfg
"!@#$%¨&*()_+
´~\'"°ºª
´~.,;<>:/*-+.,¹²³£¢¬§"
!@#$%¨&*()_+
\'1234567890-
ssdfg
{
JoaoFabioMA
Hugo
sdfgsdfgsdfg
"!@#$%¨&*()_+
´~\'"°ºª
´~.,;<>:/*-+.,¹²³£¢¬§"
!@#$%¨&*()_+
\'1234567890-
ssdfg
}
sdfgdsf
"!@#$%¨&*()_+
dsfgdfg
{
/*
JoaoFabioMA
sdfgsdfgsdfg
"!@#$%¨&*()_+
´~\'"°ºª
´~.,;<>:/*-+.,¹²³£¢¬§"
!@#$%¨&*()_+
\'1234567890-
ssdfg
Hugo
*/
}';
my $regex = qr/\{[^\}]+\}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}