$re = '/^\*\*\* NEW GIVEAWAY OPENED: \((.+?)\): Sponsored by ([a-zA-Z0-9_]{4,25})! \((\d+) Tokens - REGULAR Giveaway\) This is a promotion from CohhCarnage. Twitch does not sponsor or endorse broadcaster promotions and is not responsible for them. \*\*\*$/i';
$str = '*** NEW GIVEAWAY OPENED: (WWE 2k16): Sponsored by Tazmanianstitch! (1 Tokens - REGULAR Giveaway) This is a promotion from CohhCarnage. Twitch does not sponsor or endorse broadcaster promotions and is not responsible for them. ***
"*** NEW GIVEAWAY OPENED: (Magma Tsunami): Sponsored by StefAZenon! (100 Tokens - REGULAR Giveaway) This is a promotion from CohhCarnage. Twitch does not sponsor or endorse broadcaster promotions and is not responsible for them. ***"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);