$re = '/^([3-9]|[1-9][0-9]|100(?!\.\d?[1-9]))(\.\d{1,2})?$/m';
$str = '101010
333
100
100.00
100.01
100.10
100.11
3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);