const regex = /(?<text>[^\n]+)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<text>[^\\n]+)', 'i')
const str = `Deze kaart toont de werkelijke oppervlakte van elk land. ππΊοΈ
De wereldkaarten die we vaak zien, misleiden ons over de ware oppervlakte van landen. Deze afbeelding laat zien hoezeer onze perceptie kan afwijken van de werkelijke afmetingen van landen. `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}