#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\$INGGA.*\n\$INHDT.*\n)"
Local $sString = "$INGGA,091124.00,5249.8336,N,00120.9619,W,1,20,0.6,95.0,M,49.4,M,,*50" & @CRLF & _
"$INHDT,31.9,T*1E $INZDA,091124.0055,06,05,2016,,*7F" & @CRLF & _
"$INVTG,22.0,T,,M,4.4,N,8.1,K,A*24 " & @CRLF & _
"$PRDID,2.13,-0.06,34.09*6C" & @CRLF & _
"$INGGA,091124.20,5249.8338,N,00120.9618,W,1,20,0.6,95.0,M,49.4,M,,*5D" & @CRLF & _
"$INHDT,34.1,T*13 $INZDA,091124.2055,06,05,2016,,*7D" & @CRLF & _
"$INVTG,24.9,T,,M,4.4,N,8.1,K,A*2B " & @CRLF & _
"$PRDID,2.16,-0.03,36.24*61" & @CRLF & _
"$INGGA,091124.40,5249.8340,N,00120.9616,W,1,20,0.6,95.0,M,49.4,M,,*5A" & @CRLF & _
"$INHDT,36.3,T*13 $INZDA,091124.4055,06,05,2016,,*7B" & @CRLF & _
"$INVTG,27.3,T,,M,4.4,N,8.1,K,A*22 " & @CRLF & _
"$PRDID,2.11,-0.05,38.33*68" & @CRLF & _
"$INGGA,091124.60,5249.8343,N,00120.9614,W,1,20,0.6,95.1,M,49.4,M,,*58" & @CRLF & _
"$INHDT,38.4,T*1A $INZDA,091124.6055,06,05,2016,,*79" & @CRLF & _
"$INVTG,29.5,T,,M,4.4,N,8.1,K,A*2A " & @CRLF & _
"$PRDID,2.09,-0.02,40.37*6D" & @CRLF & _
"$INGGA,091124.80,5249.8345,N,00120.9612,W,1,20,0.6,95.1,M,49.4,M,,*56" & @CRLF & _
"$INHDT,40.4,T*15 $INZDA,091124.8055,06,05,2016,,*77" & @CRLF & _
"$INVTG,31.7,T,,M,4.4,N,8.1,K,A*21 " & @CRLF & _
"$PRDID,2.09,0.02,42.42*40" & @CRLF & _
"$INGGA,091125.00,5249.8347,N,00120.9610,W,1,20,0.6,95.1,M,49.4,M,,*5F" & @CRLF & _
"$INHDT,42.4,T*17" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")