package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`9[|][^#]*4`)
var str = `7|1#9|1,5,7#10|2,4,51#
7|1#9|1,4,5#10|1,3,38#
7|1#19|1,14,5#10|1,3,38#
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}