use strict;
my $str = 'sd{f(tagsad<fas>df(tag(a)sd)sdfa(sdf)s[a(sd)]f)as}df';
my $regex = qr/^([^()[\]{}<>]*)(\(((?1)(?2)*)*\)|\[(?3)*\]|<(?3)*>|{(?3)*})(?1)$/p;
if ( $str =~ /$regex/ ) {
  print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
  # print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
  # print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}