re = /^(([NEW]|S[WS]*N)*S[WS]*E([ES]|W[WS]*E)*W[WS]*N)*([NEW]|S[WS]*N)*S[WS]*E([ES]|W[WS]*E)*N[NEWS]*$/
str = 'SNSEN'
# Print the match result
str.match(re) do |match|
puts match.to_s
end