#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)#-=-=-= AUTOGENERATED HEADER =-=-=-.*?#-=-=-= AUTOGENERATED FOOTER =-=-=-"
Local $sString = "#-=-=-= AUTOGENERATED HEADER =-=-=-" & @CRLF & _
"a=b" & @CRLF & _
"c=d" & @CRLF & _
"x=y" & @CRLF & _
"#-=-=-= AUTOGENERATED FOOTER =-=-=-"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")