re = /^([0-9][0-9][0-9][0-9])-(0[1-9]|1[012])-(0[1-9]|[12][0-9]|3[0-1]) ([01][0-9]|2[0123]):([0-5][0-9]):([0-5][0-9])$/
str = '"2022-05-01 00:00:00"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end