$re = '/{\s*(?:customer|car):(\d+)\s*}/m';
$str = '{ customer:1501 } bought a car { car:6333 }';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);