package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?(\.ovh\b)[^$]*)$`)
var str = `[test@test.ovh](mailto:test@test.ovh)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}