re = /\w*(ee|me)\w*(*SKIP)(*FAIL)|e/m
str = 'met
meet
eel
elm
degree
zookeeper
meee'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end