const regex = /^[A-Za-z0-9\u0430-\u044F\u0410-\u042F\._-]+@([A-Za-z0-9\u0430-\u044F\u0410-\u042F]{1,2}|[A-Za-z0-9\u0430-\u044F\u0410-\u042F]((?!(\.\.))[A-Za-z0-9\u0430-\u044F\u0410-\u042F.-])+[A-Za-z0-9\u0430-\u044F\u0410-\u042F])\.[A-Za-z\u0430-\u044F\u0410-\u042F]{2,}$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Za-z0-9\\u0430-\\u044F\\u0410-\\u042F\\._-]+@([A-Za-z0-9\\u0430-\\u044F\\u0410-\\u042F]{1,2}|[A-Za-z0-9\\u0430-\\u044F\\u0410-\\u042F]((?!(\\.\\.))[A-Za-z0-9\\u0430-\\u044F\\u0410-\\u042F.-])+[A-Za-z0-9\\u0430-\\u044F\\u0410-\\u042F])\\.[A-Za-z\\u0430-\\u044F\\u0410-\\u042F]{2,}$', 'i')
const str = `дсацс@абсд.бг`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}