using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"foo\/(.+?)(?=-fo)";
string input = @"http://test-url/foo/qux-fo/";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}