package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)#((?:[\s\S]*?людовик[a-z]*)+)`)
var str = `
ЛюдовикXV, ЛюдовикXVI, ЛюдовикXVIII, ЛюдовикLXVII, ЛюдовикXXL
ЛюдовикXV, ЛюдовикXVI, ЛюдовикXVIII, ЛюдовикLXVII, ЛюдовикXXL
# ЛюдовикXV, ЛюдовикXVI, ЛюдовикXVIII, ЛюдовикLXVII, ЛюдовикXXL
ЛюдовикXV, ЛюдовикXVI, ЛюдовикXVIII, ЛюдовикLXVII, ЛюдовикXXL
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}