#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^([0-9]:)?([0-9]+[a-zA-Z0-9~.+]+)(-[0-9]+[a-zA-Z0-9~.+]+)?"
Local $sString = "1.0+32-s1beta1~svn1245"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")